Subscribe to updates
Powered by
Global outage of production instances
Resolved
·
Full outage
Service is back to normal
Thu, Feb 26, 2026, 04:42 PM
(
2
months ago)
·
View all updates
Affected components
Feb 26, 2026, 04:30 PM
04:42 PM
App
Updates
Resolved
Service is back to normal
Thu, Feb 26, 2026, 04:42 PM
Identified
The product is entirely unavailable
Thu, Feb 26, 2026, 03:47 PM
(
55
minutes earlier)
Global outage of production instances - DataGalaxy Status